Posts Tagged ‘automatic update’

Upgrading wordpress 2.7 to 2.7.1

Saturday, February 21st, 2009

I was just trying to upgrade WP 2.7 to 2.7.1 and got this error:

“Downloading update from http://wordpress.org/wordpress-2.7.1.zip

Unpacking the core update
Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/sneely/webapps/wordpress/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421)”

It turns out that the problem was from the WordPress Automatic Upgrade plugin. Ryan posts that this is because WP 2.7 has its own autoupgrade included so we no longer needed WPAU.

If you get the same error just deactivate the automatic upgrades plugin and try again.